How to add Thumbnail Image Inside the Teaser box of Thesis Theme

Thesis theme offers options to enable thumbnail image in teaser box at homepage. Before going to add image in teaser you should check whether teaser enabled or not. There are two ways to add thumbnail in teaser. First you can give only post image while writing post which may be in any size. It will be automatically inherited in teaser box and crabbed into a fixed size that has been specified in the default thumbnail options in this case you don’t give image url in thumbnail image section. He we have options to select whether you need the same thumbnail image inside the post or not.

credit

The second way is add image directly in thumbnail image section it will display original size pf the image that you have uploaded in the media. The second method you should previously resize the image into fixed size before uploaded into library. To add thumbnail you need to know how to upload image in media library. If you know well proceed further. Because in this tutorial I am get image link directly from media library.

This video explains about….

How to enable teaser box in home page.?

How to check whether teaser enabled in Thesis homepage or not?.

How to add thumbnail image inside the teaser box.?

Necessary teaser display options needed to display image in teaser box.

Also gives the detail about where you need image inside the teaser box left or right.

Where you need image in homepage only or also need single pages and archive pages?

Share your experience in comment section. For more checkout our all Thesis theme tutorials..

{ 29 comments… add one }

Leave a Comment

  • Tom | Build That List February 13, 2010, 3:29 AM

    That is great! I have thesis on one of my blogs and I was wondering how to do this!

    Reply
  • Pascal February 13, 2010, 10:28 PM

    Thanks tom, keep reading our blog we will add more tutorials in future.

    Reply
  • Pascal February 13, 2010, 10:27 PM

    Thanks vivek, keep reading our blog.

    Reply
  • Black Host March 13, 2010, 6:07 PM

    Hello My Friend

    I just tested this feature out. My site was previously set to show teasers without images.

    I watched your tutorial and updated one post to show thumbnail in teaser on homepage.

    It works perfectly EXCEPT, now my page takes 5-7 seconds to load. What could this be do to. Please test it out.

    Reply
  • Pascal March 14, 2010, 6:37 PM

    Hi,

    When i tried your blog, it loaded fast. Do you still face same issue?

    Reply
  • blackhost March 14, 2010, 7:12 PM

    Thanks for the response.

    I removed the images from teasers as I could not fix the page load time. I had set only 1 teaser post with a small image, and it took about 7 seconds to load the page.

    It is not worth it for me to spend any more time on this, so I removed the images from teasers.

    Thanks

    Reply
  • Pascal March 14, 2010, 7:35 PM

    Ok.

    Usually adding images in teasers, navigations or blog background & more javascripts will increase the page load time..When we use images in fourblogger teasers, it happened to us…we removed them…

    Thanks for making use of our tutorials…

    Reply
  • Keith Carey March 20, 2010, 1:00 PM

    I followed step by step what you said and I am not seeing the thumbnail in the post. And I did it 3 times. What am I doing wrong? Thanks

    Reply
  • Keith Carey March 23, 2010, 2:50 PM

    Im trying the use the instructions you give here but after about 10 trys, I’m still not seeing the thumbnail image in the teaser box. What might I be doing wrong?
    Please help–thanks

    Reply
  • Pascal March 23, 2010, 11:41 PM

    Where you gave link for thumbnail image link?

    Make sure you gave the link in Post image Url box at Post Edit page.

    Reply
  • Yiannis April 30, 2010, 3:29 PM

    Hello

    thank you for the replies they were very helpful

    one another thing i like to ask you is that i want to put in my blog thumbnails that when you click them they expand something like the themes that you preview in wordpress

    any ideas on that? is that css or a plugin?

    thank you and keep up the amazing posts

    Reply
  • Suresh April 30, 2010, 7:19 PM

    hai,

    I saw your site there is no thumbnail image.. image available only inside the post.. if you click on image inside the post it will expand.
    but if you added thumbnail ..and click on this image it will go inside the post from teaser..

    Reply
  • Yiannis April 30, 2010, 7:50 PM

    Hi Suresh

    i added a thumbnail in my poste (latest post) and when i click on it it still opens in a new page

    Reply
  • Suresh April 30, 2010, 10:02 PM

    hai,

    I checked now thumb nail image works fine..

    Reply
  • Allyster May 21, 2010, 9:06 AM

    Got them! ! ! Big help for me. . .:)

    Reply
  • Curious Little Person October 8, 2010, 1:27 AM

    the thumbnail image is not showing , but it is showing in the post, can u help

    Reply
  • Curious Little Person October 8, 2010, 10:11 AM

    sorry, there was a issue with the picture – it’s working fine now… thks

    Reply
  • brandon October 29, 2010, 7:47 AM

    Hello,
    I am trying to post thumbnails in my teaser boxes. Here is the link:
    http://www.acronymdesigns.com/skunkworks

    At first they displayed just fine…now after some css tweaking for the thumbnail layout, the images do not display.

    Can I please have some advice?
    Thank you:)

    Reply
  • Lalit January 22, 2011, 12:15 PM

    Hello..
    i am trying to add images to teasers from past 20 days. I followed the steps explained in the video but my images are not displayed in the teasers. Please help. Thanks!

    Reply
  • mustafa February 10, 2011, 3:06 AM

    Hi, pascal i try and i realized that : utomatic thumbnail generation requires your image to be hosted at your web site not another web site ..
    i give tinypic adress not show but i give my site adress it show can i change this?

    Reply
  • paul March 3, 2011, 2:00 PM

    Hi Pascal, BTW, thanks so many TUT about thesis customization.
    just want to ask if wthat am i doin wrong, i cant get my image thumbnail teaser to wrong, try it to may times but it still not showing, do all the step but it still not showing, can you help me?

    Reply
  • anuj@webtricksblog March 6, 2011, 10:14 PM

    i am using your tip to add thumbnail in thesis theme what its showing two images in feed ,any idea ?

    Reply
  • söve April 13, 2011, 1:11 PM

    Thank u for posting.

    Reply
  • LynnW April 23, 2011, 3:42 AM

    Wanting to view the video but it’s giving an error.
    Using your Featured Posts inside the Feature Box, and it’s working well.
    Tried 4 other ways to get a silly thumbnail image to show in the featured box with each of the 2 posts, but to no avail. Hoping pairing your image idea with your featured post box idea will work….

    Reply
  • Fusiondairy June 11, 2011, 5:41 AM

    I like the way you come right to the key points in your tutorials. No beating around the bush and just no fluff.

    Thanks for helping me with the featured image option.

    I am looking for a way to display post excerpts and a featured image in category pages. Will be checking you blog (just in case you come up with something)

    Reply
  • Kamal Patel October 18, 2011, 12:49 AM

    I tried this …my image shown as full size image on the the blog page…

    i tried it as shown in video…i got these same error before also i tried this….can you please tell me whats the reason behind that .??

    Reply
  • FourBlogger October 19, 2011, 11:08 AM

    Make sure that you have set the options correctly in teaser, and give thumbnail size.

    Reply
  • Kamal Patel October 19, 2011, 11:23 AM

    Yeah I tried it as you said and shown in video…but dont know whats wrong with that….it shows full width image…
    im using 125*125 thumbnail size, but showing full width image….may b i made some mistakes at some end…but not done anything different as you shown in video….i will try to check it out on other things.

    Reply
  • Victor Barba March 18, 2012, 1:37 AM

    Hello 4Blogger,

    First of all i want to tell that you have a great site full of amazing tutorials.

    I’d like to comment that i have a problem related to thumbnail images.

    The problem is that when somebody shares some post with share buttons (Facebook and Linkedin) there is no a thumbnail image to share and i don’t know why is hapenning this, i tried everything but i haven’t been able to solve it.

    Do you have any idea that can help me to share posts on facebook and linkedin with a thumbnail image?

    Maybe it’s due to there is no featured image box option in posts, i really don’t know how to fix it.

    Thanks in advance.

    Reply